Disclaimer: VSS is an OS component, the steps mentioned below should only be performed by your system admin and/or after consulting Microsoft. We cannot take responsibility for faults caused by following the below steps.
VSS error codes and their solutions:
Code |
Description |
0x8000ffff |
The Shadow copy provider had an error. Please see the system and application even logs for more information. |
The client log shows the error: 0x8000ffff [Catastrophic failure]. Continuing with actual volume...
Cause:
· The COM+ Event System service is not started.
· The Volume Shadow Copy service is not started.
Solution:
Launch services.msc from the “Run” option on the “Start” menu and set parameters of the following services as shown below:
Services |
Status |
Start up Type |
COM+Event System |
Automatic |
Started |
Volume Shadow Copy |
- |
Manual |
Code |
Description |
0x80042304 |
The shadow copy provider had an error. Please see the system and application event logs for more information. |
The client log shows this error: 0x80042304: The volume shadow copy provider is not registered in the system.
Cause:
· Volume shadow copy DLLs are corrupted.
Solution:
Stop the
Volume Shadow Copy service. Open a Command prompt window using the cmd command.
At the command prompt enter
c:\> net stop vss
To change
the directory path, enter
c:\> cd C:\WINDOWS\System32
Register
the following DLL files. Make sure you are in the Windows\System32 directory.
At the command prompt enter:
c:\Windows\System32>regsvr32
ole32.dll
c:\Windows\System32>regsvr32 oleaut32.dll
c:\Windows\System32>regsvr32 vss_ps.dll
c:\Windows\System32>Vssvc /Register
c:\Windows\System32>regsvr32 /i swprv.dll
c:\Windows\System32>regsvr32 /i eventcls.dll
c:\Windows\System32>regsvr32 es.dll
c:\Windows\System32>regsvr32 stdprov.dll
c:\Windows\System32>regsvr32 vssui.dll
c:\Windows\System32>regsvr32 msxml.dll
c:\Windows\System32>regsvr32 msxml3.dll
c:\Windows\System32>regsvr32 msxml4.dll
Restart the
Volume Shadow Copy service. At the command prompt, enter:
net start vss
Code |
Description |
0x80042306 |
The shadow copy provider had an error. Please see the system and application event logs for more information. |
This error occurs when a VSS provider blocks the creation of the VSS snapshot.
Cause:
· Installing a new 3rd party VSS provider.
· An existing provider becoming corrupted.
· Destination drive not being compatible with NTFS format.
To check this problem, run NTBackup and try performing a manual backup of your System State. If it is a VSS problem, the backup will fail.
If NTbackup is successful, check your scheduling to make sure that the backup does not clash with other system activity. Otherwise, follow the instructions given below.
Solution:
· VSS Providers.
Check to
see if there are any non-standard providers that are causing the problem when
creating a VSS snapshot. To do this, go to the command prompt and use the
following command:
vssadmin list providers
If there are any non-standard providers listed, consider uninstalling them.
Note that the Microsoft default providers are generally very reliable, so
uninstalling 3rd party providers may solve the problem.
If the "vssadmin list providers" command hangs, it is likely that a
newly installed VSS provider is malfunctioning. In this case, uninstall these
products to resolve the issue.
· Multiple Backups.
Ensure that another backup is not running at the same time, as the custom provider may only allow one snap-shot at a time.
· Corrupted data on the drive to be backed up.
Run the CHKDSK command on each drive with the /f switch to fix any errors on the disk.
· VSS believes the system is in setup process.
Check the
status of the system by following these steps:
a. Go to the Registry Editor and locate HKEY_LOCAL_MACHINE\SYSTEM\Setup
b. Ensure that the following registry values are set to 0:
SystemSetupInProgress
UpgradeInProgress
· VSS dll`s are corrupted
Re-install
the VSS dll`s by following these steps:
a. Using command prompt, CD to the WINDOWS\system32 directory.
b. Stop the Volume Shadow Copy service by executing the command "net stop
vss".
c. Register the DLLs (See
point 7 on this guide)
· COM+ needs to be re-installed
Re-install
COM+ by following these steps:
a. Backup and then delete HKLM\Software\Microsoft\COM3.
b. Boot to Recovery console and rename clbcatq.dll to ~clbcatq.dll. Make sure
to use the tilde (“~”) character.
c. Boot the machine to normal mode and in Control Panel, open the Add or Remove
Programs tool and then open the Add/Remove Windows Components tool. Do not Make
any changes, just click Next. This reinstalls COM+.
· Destination drive is not formatted for NTFS
Code |
Description |
0x80042308 |
The specified object was not found. |
This error shows the backup process is having difficulties with backing up open files.
Cause:
· Problem with VSS when backing up open files, or files that are in use.
Solution:
1. Change directory to System32
c:\>cd c:\Windows\System32
c:\Windows\System32>Net stop vss
c:\Windows\System32>Net stop swprv
Register the DLLs (See
point 7 on this guide)
2. Reboot
machine, open cmd and run the command
vssadmin list writers
Check results and ensure they are all displayed without errors.
Code |
Description |
0x8004230c |
Shadow copying of the specified volume is not supported. |
When you
try to revert a volume on a shared cluster disk, or on a cluster shared volume,
to an earlier version by using Volume Shadow Copy Service (VSS), the following
error message is logged in the VSS log file:
Shadow copying the specified volume is
not supported.
Cause:
· A required service has been disabled or not started properly.
Solution:
Follow the procedure given below.
1. Open the Control Panel.
2. Click Classic View in the Tasks pane.
3. Double-click Administrative Tools.
4. Double-click Services.
5. Scroll down and double click the Microsoft Software Shadow Copy Provider.
6. In the Start-up Type menu, select Automatic.
7. Click the Start button, Click Apply / OK.
Next, scroll down to the Volume Shadow Copy service and perform the same steps. Exit and reboot the computer.
Code |
Description |
0x80042312 |
The maximum number of volumes for this operation has been reached. |
0x80042317 |
The specified volume has already reached its maximum number of shadow copies. |
The limitation in number of shadow copies per volume is 64. This is the reason that VSS_E_MAXIMUM_NUMBER_OF_VOLUMES_REACHED error occurs when you try to create 65th volume shadow copy.
When the storage limit is reached, older versions of the shadow copies will be deleted and cannot be restored. There is a limit of 64 shadow copies per volume that can be stored. When this limit is reached, the oldest shadow copy will be deleted and cannot be retrieved.
Cause:
· Specified volume has reached its maximum number of shadow copies.
Solution:
Delete the oldest shadow copy for the drive, this should clear out the error. The
CMD command for this is:
vssadmin list shadows
You will see the following:
To delete
the oldest, run this command in CMD:
vssadmin delete shadows /For=C: /Oldest
Enter “y” to delete.
Code |
Description |
0x80042313 |
The shadow copy provider timed out while flushing data to the volume being shadow copied. |
Check if the Volume Shadow Copy services are started:
· Open Control Panel > Administrative tools > Services
· Find Volume Shadow Copy service and check if it is running, if no press “start” on the left.
Cause:
VSS is failing due to high disk activity, this stops VSS creating shadow copy
in the default time period when volumes are frozen for a snapshot.
Solution:
Perform the backups during a time of less disk activity to avoid this.
Code |
Description |
0x80042314L |
VSS encountered problems while sending events to writers. |
The system was unable to hold I/O writes.
Cause:
This can be a temporary problem.
Solution:
It is recommended to wait ten minutes, then try it again.
Code |
Description |
0x80042315 |
An error occurred while trying to contact VSS writers. Check for associated errors in the event log. |
Cause:
Problem with the VSS performing backups of any open files or folders that are
in use at the time.
Solution:
Check if the Volume Shadow Copy service are started:
· Open Control Panel > Administrative tools > Services
· Find Volume Shadow Copy service and check if it is running, if not press “start” or “restart” on the left.
Code |
Description |
0x80042316 |
Another shadow copy creation is already in progress. Please wait a few moments and try again. |
Cause:
This warning usually indicates VSS being unable to run due to another instance
of VSS already running.
Solution:
1. If more than one backup program is installed, disable the programs except
for this one and run the backup again.
2. The previous VSS snapshot has not completed and is still running. Stop and
re-start the Volume Shadow Copy service in Control Panel > Administrative
tools > Services, find Volume Shadow Copy, highlight and select “restart”. Alternatively
you can restart the machine, this usually does the above.
3. Register the DLLs (See
point 7 on this guide)
Code |
Description |
0x80042318 |
An error occurred while trying to contact VSS writers. Check for associated errors in the event log. |
The writer infrastructure is not operating properly.
Solution:
Check that the Event Service and VSS have been started, also check for errors
associated with those services in the error log.
Code |
Description |
0x8004230f |
The shadow copy provider had an unexpected error while trying to process the specified operation. |
Cause:
VSS system files are not registered, or the MS Software Shadow Copy Provider is
not started.
Solution:
Set MS Software Shadow Copy Provider service to Manual by going to Control
Panel > Administrative tools > Services, highlighting this service and pressing
“manual” on the right.
If that
does not work, open CMD and enter in the following commands individually.
c:\>cd /d %windir%\system32
c:\Windows\System32>Net stop vss
c:\Windows\System32>Net stop swprv
Register the DLLs (See
point 7 on this guide)
Code |
Description |
0x80042326 |
The volume being reverted was lost during revert. |
Sometimes the VSS writers will fail because of time-out errors, these cause the backup to fail. VSS writer is a service or program that uses the service to save information to a shadow copy storage area.
Cause:
This problem occurs especially on computers that have slow hard disks, low
memory, low CPU speed or on computers that have the disk write cache disabled.
Solution:
Ensure you have the latest service pack for Windows installed.
Code |
Description |
0x80042321 |
Some shadow copies were not successfully imported. |
When using VSS to create more than 10 transportable hardware snapshots, some of these snapshots may not be imported within the allocated time. If the snapshots are not imported, the import operation fails.
Cause:
This problem occurs because of low time-out values. VSS does not wait long
enough for the logical unit numbers (LUNs) to come online. This problem occurs
when hardware arrays approach the VSS limit of 64 shadow copies per shadow copy
set.
Solution:
Ensure you have the latest service pack for Windows installed.
Code |
Description |
0x80040154 |
Error creating shadow copy provider COM. |
Event ID: 12292 & Event ID: 22
When a backup starts, inSync creates a snapshot of backup folders using VSS. Then, inSync creates a backup of this snapshot. If the snapshot creation fails, inSync backup fails. inSync does not take volume backups from the file system.
Cause:
A third party provider is being used to perform a shadow copy instead of the
system provider (Microsoft Software Shadow Copy provider 1.0). The third-party
shadow provider keeps failing while taking a shadow copy.
Solution:
1. Check the VSS providers using the following command to confirm if there is a
third party provider on the machine:
vssadmin list providers
2. Force
VSS to always use Microsoft Software Shadow Copy provider by making the
following registry entries:
NOTE: incorrect use of Regedit can
prevent the OS from functioning properly. *
a. Click Start, click Run, type regedit, and then click OK.
b. Locate the following registry subkey, and then right-click it:
HKey_Local_Machine\SYSTEM\CurrentControlSet\Control\BackupRestore
c. Point to New, and then click DWORD Value.
d. Type UseMicrosoftProvider as the
name for the new DWORD value, and then press ENTER.
e. Double-click UseMicrosoftProvider.
To enable the new feature, type 1 in the Value box. To disable the new feature,
type 0 in the Value box.
f. Press ENTER, and then exit Registry Editor.
3. Restart the server.
4. Run another backup, should complete successfully.
5. Optional: uninstall the other software that was being used earlier.
*it is recommended to take a full backup of the registry and workstation prior to making any changed in regedit.