Storagecraft SPX Management Console: Cannot Connect to Service Due to Proxy

Storagecraft SPX Management Console: Cannot Connect to Service Due to Proxy

Problem

StorageCraft® ShadowProtect® SPX fails to load when opened. In %localappdata%\StorageCraft\spx-gui\log\spx_gui.log, the following error is found:

NoConnection: HTTPS Connection to ../version failed with error Cannot Connect:
Connection to 'https://127.0.0.1:13581/spx/version/'; failed: HTTPSConnectionPool(host='127.0.0.1', port=13581): 
Max retries exceeded with url: /spx/version/ (Caused by ProxyError('Cannot connect to proxy.', error('Tunnel connection failed: 407 Proxy Authentication Required',)))
Cause
Proxy settings in Internet Options are preventing connection to the SPX service.

Resolution
Below are the steps to verify the proxy settings to allow communication to flow between SPX and the service:
Open Internet Options > Connections > LAN Settings > Proxy server > Use a proxy server... to check if a proxy server is enabled.
If a proxy server is configured, ensure that Bypass proxy server for local addresses is checked.
Apply the settings then attempt to open SPX.
If starting the service fails, move to the next steps to manually enter in the local host as an exception.
From LAN Settings > Proxy Server, select the Advanced tab.
Enter 127.0.0.1 (the default address for localhost) in the Exceptions section (or the FQDN or IP if the SPX session is using those).
Attempt to start ShadowProtect SPX again.

If the service continues to fail, please contact us at support@safedatastorage.co.uk.


    • Related Articles

    • System Requirements and Installation instructions of SPX for windows - Safe Image

      Windows Installation You can install the SPX console and SPX agent together or separately. System Requirements Component SPX Requirement CPU 300 MHz or higher Pentium-compatible CPU Memory The greater of 256 MB or the Operating System minimum Hard ...
    • How to Manually activate SPX - SAFE Image

      1. Go to https://www.storagecraft.com/activation 2. Fill in customer information and serial number 3. Stop SPX service 4 Start SPX service 5 in C:\ProgramData\StorageCraft\spx open license.activate in notepad and copy content to the activation form ...
    • Setting up StorageCraft SPX - Safe Image

      To install SPX and create a continuous backup job on a Windows system: Create a backup folder to act as a destination for backup image files. This destination can be an: External hard drive NAS system on the same network Backup/Disaster Recovery ...
    • QuickBooks Issue with backup sizes using StorageCraft SPX - SAFE Image

      Problem Storagecraft will sometimes generate big images when QuickBooks is installed on the target machine. The QuickBooks Transaction log (TLG file) can sometimes start to generate big files if it is not maintained properly which leads to the backup ...
    • StorageCraft Downloads - Safe Image

      Please Note: these download links are for our Safe Data Storage Clients only, and will only work with the product keys we issue. If you require a key for a trial or need our help setting this up then please contact us on 01689 661030. StorageCraft ...